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1 Introduction to Forms and Reports  

In this chapter you’ll learn how to setup forms to enter, edit and view data in the Pass IT Driving 

school database.    

Forms provide a user-friendly on-screen interface for data entry.  

You are also going to be developing reports which are documents that presents data in an easyto-

read, professional format.  In this case the results of database queries are presented in an 

attractive format, with headings, fonts and colours designed to enhance understanding of the data.     

2 Get the right database  
1. From the study directory > unit 2 > databases download the database called  

“DrivingSchool chap 3 with queries”  

2. Please move it into your Unit 2 folder in your user area and open it  

  

3 Validation recap  
1. Open tblStudent in Design view  

2. Create a validation rule in Surname, Firstname, Address1 and Mobile number to make these 

required fields (hint: the opposite is IS NULL!)  

3. Save tblStudent and close it  

4. Go through the rest of the tables and add the same validation rule where you think it is 

needed  

4 Forms - Setting up the Student form  
1. In the database window select Create > Form Wizard  

  

2. Select tblStudent from the dropdown, then click Next  
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   In the Form Wizard window you can either  select single fields  

by selecting the single arrow    

   Or  all   the fields by selecting the  double a rrow   

  

  
  

3.   For the student form, please select  all   the available fields and then click  next   

  

4.   From the next window select  Columnar   ( columnar layout will show you one record at a  

time)   and select  Next   
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5. In this window alter the title of the form so it matches our naming convention frmStudent  

   

6.   The form will open in  Form   view   

  

  

7.   You’ll be working in different “views” as you develop your forms.   
Find the  View   button and have a look at  Layout view  and  

Des ign view   
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4.1 Working in Form Design View  

 

  

  

6. A form footer section which can be used in the same way as the Header  

 

    

 

 

 

 

 

 

1.   Close   frmStudent   and in the Database Window  right click   on  frmStudent   and select  

Copy   then  Paste .  In the Paste As box name it “ frmStudentCopy ” .   

2.   Open frmStudentCopy  in design view and find all these elements:   

  

3.   Form Header   section   -   this area can contain text, headings, titles and graphics   

  

4.   Detail section   –   this contains the controls that display the data from your tables or queries   

  

5.   A number of Controls   each made up of a  Label   containing the  field name   and   a text box   

which will contain  the data in Form view   
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7. Right margin can be dragged wider using the mouse  

 

b. Arrange tab enables you to adjust the layout of your controls to ensure they are 

aligned correctly with consistent sizes and even spacing  

 

  

  

8.   Ruler   and  Grid   help you with the layout of your form.     

9.   The  form  design tools   menu (you’ll find this at the top of the screen)  has  

three tabs to help you  Design ,  Arrange   and  Format   your forms   

a.   Design tab   enables you to add text, lines, shapes, controls, buttons , images   

and other features   

  

  

c.   Format tab   helps you to   add formatting such as font colour, alignment (left, right  

and centre) etc   
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4.1.1 Working with controls  

1. The Detail section is made up of controls which display the data from your 

tables or queries  

2. The controls are made up of text boxes, check boxes an attached labels  

3. Its worth practising all the following steps on the frmStudentCopy and  

practicing all the following steps until you feel confident  

4. Open frmStudentCopy in Design view  

  
6. Move your mouse to the edge of the control until it changes to a four headed arrow, you can 

now move the control.  Also try resizing the control  

4.1.3 Selecting the label and the textbox.  

7. Click on the label of any control, then hold the shift (or control) key down and select the 

textbox.  Both are now highlighted, see what happens when you resize now  

  
8. To select more than one control, either drag a rectangle around the controls you with to 

select or hold down the shift while selecting controls  

4.1.4 Deleting controls  

9. To delete a control, simply highlight and press delete on the keyboard  

4.1.5 Adding a control  

10. If you want to add a control for a field go to Form Design 

Tools > design tab and find the Add Existing Fields 

icon.  Click on it, select the field you want and drag it on 

the form  

  

  

    

4.1.2 Selecting controls   

5.   To resize, delete, copy of change the properties of a control you first select it.   

Simply  click anywhere on the  label of any  control   and it will be highlighted with sizing  

handles   
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4.1.6 Aligning controls  

 
13. In Form Design Tools > Arrange tab find the align tab and select left.  

14. “play” with the options in Align and Size/Space to tidy up the form.  

15. You are aiming for a nicely aligned form with consistent spacing between the controls   

16. Go to Form view to check how it looks  

17. Save when you have finished  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

11.   From the database window, open  frmAlignmentPractice .  This form is a bit  

messed up and will give you a chance to practice aligning controls   

12.   Drag a rectangle around the co ntrols on the left of your form   
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4.2 Fonts, colours and special effects  

18. Open FrmStudentCopy in Design view  

19. Open the Form Design Tools tool bar on the Format tab.    

20. Click into the Detail area of your form and select an appropriate fill colour  

21. Highlight the controls (drag a rectangle around them) to change the font colour  

22. From the Design tab select the Rectangle  

 

23. Draw a rectangle around the controls and then click on the rectangle   

24. Select the Property sheet icon from the Design tab and the property sheet will appear  

 
25. (with the rectangle highlighted) In the Format tab of the Property Sheet, go down to Special 

Effect and select “Etched” from the drop down list.  

26. Check out the effect by saving your form and viewing it in Form View.    

27. Try the other Special effects to see what can be done  

  

  

on the right of your screen   
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4.2.1 Adding graphics to the form  

Graphics can easily be added to your form.    

1. Go to the Study Directory > unit 2 > databases and download the image 

called “pass IT driving school logo” and move it into your unit 2 folder on your  

user area  

2. In the Design View of your frmStudentCopy click into the Form Header area and change 

the label to something more user friendly such as “Student Details”  

3. From the Design tab select “insert image” and then browse for the logo  

 
4. In the form header area, draw a rectangle where you want the image to be placed and it 

will appear  

5. Click on the image and then go to 

the  

Property Sheet (if its not showing 

click on the Property Sheet icon in 

the design tab).   

6. In the Format tab see what 

happens when you change the 

size mode from “Zoom” to 

“Stretch”   

7. You can change the special effect 

to a different mode e.g. raised or 

sunken  Save  

8. Check out the image in Form View  
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4.2.2 Layout view  

1. So far you’ve been working in Design view, 

Layout view can also be used to make design 

changes to your forms.  

2. Have a “play” with frmStudentCopy in Layout 

view and see if you can do the same things as Design view.  You 

can work out which view you prefer to work in  

  

 4.3  Practice Time  

 

  

2. Use Design View or Layout view to create a well-designed, accessible form that includes:  

• Good alignment and regular spacing  

• High contrast colour scheme  

• Suitable and accessible fonts  

• Field widths are suitable for the data that is going to be entered  

• Sensible, user friendly Title  

• The Driving school logo  

• Evidence of rectangles or lines with special effects applied  

• A generally well designed, easy to use form  

  

4.4 Practice - Create New Forms  

1. Using the Form Wizard, create a columnar form from tblInstructor, using all the fields.  

Make sure it is named correctly  

2. Using Form Wizard, create a tabular form from tblLessonType using all the fields. Make 

sure it is named correctly  

3. Use Design or Layout view to ensure they are well designed, user-friendly forms  

1.   Open  frmStudent   and use either Design View  or Layout to move the  

commands from  ‘ Phone No ’   down to  ‘ Passed Practical Test ’   to the right hand side  

of your form, like this   
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4.5 Setting Form Properties  

You can control the behaviour and appearance of your forms by setting 

the form’s properties.  In your forms you can alter the features that are 

currently showing such as Record Selector, the Records navigation 

Controls, Maximize and  

Minimize and Close buttons  

Open frmStudent in Design View and show the Properties Sheet  

Click on the Form Selector at the top left of the form in Design View  

6. In the Properties Sheet  Format tab make the 

following changes:  

  

a. Change the Caption to Student Details (in  

Form view you’ll notice that the form’s tab now 

shows “Student Details”  

b. Auto Center to Yes  

c. Record Selectors to No  

d. Change Scroll bars to Neither  

e. Min Max Buttons to None  

7. Your finished form should look more user friendly now  

4.5.1 Practice  

8. Apply these techniques to frmInstructor  

    

4.   

5.   
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4.6 Disabling and Dimming Fields  

 

  

4. In Form view you’ll see that the field is disabled and dimmed  

  
5. Go ahead and do the same for Instructor ID in frmInstructor  

4.7 Adding Labels  

Labels can improve the user-friendliness of a form and makes it clear and more intuitive.  

1. Open frmStudent in Design view  

2. We are going to add buttons to the lower section of the form so you will have to drag the 

Form Footer area down to create a little room  

  

Access provides a number of ways to prevent users from  inadvertently changing  

data on their forms.  One way i s to  d isable and dim   certain  fields.   

It would be expected that any Primary key that is an Autonumber datatype would  

be disabled and dimmed so a user doesn’t attempt to change it.   

1.   Open  frmStudent   in  Design   View   

2.   Select the   primary key which is the  StudentID   control   

3.   In the  Properties Sheet   go to the  Data   tab and  set the  Enabled Property  

to No   ( make sure Locked property to No )   
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3. From the Form Design Tools select the Design tab select the label icon  and draw a 

label in the bottom left of the Detail area  

4. In the label add the following text “Use this form to add and edit student’s details.  You must 

enter data where * appears”.    

a. Use the design tab to make sure the font is visible and accessible.    

b. You can also centre the text in the Design tab.    

c. Use the field properties area to add a special effect to the label (e.g. raised or 

embossed)   

 
5. Hint: to get the text to appear on the next line use shift +  enter (not just enter)  

4.7.1 Putting an asterisks next to required fields  

6. As part of effective form (interface) design you should indicate which fields the users must 

complete – i.e. required fields  

7. Open frmStudent in Design view and make a label, in the label type an asterisk and 

format the font red. Put the label next to one of the required fields (e.g. Surname)  

8. Position the label next to the required field.    

9. Copy the label as many times as needed and position by all the required fields.  

10. Hint: once you have copied and pasted the labels it is easier to position them using Layout 

view  

11. Make sure you put the asterisks in a consistent place next to the required fields to make 

sure your interface looks professional  

  

  

4.7.2 Practice  

12. Now apply these skills to frmInstructor  
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4.8 Adding Command buttons  

Access allows you to automate tasks by creating command buttons and placing 

them on your form  

Command buttons can be added to dead with a number of operations including  

• Record navigation  

• Opening forms and reports  

  
4. The Command Button Wizard will appear.  From the categories list select Record 

Operations and select Add New Record and click Next  

 
5. On the next screen select Text and alter the text to read New Student and click Next  

6. On the next screen type in the name for this command button – you’ll use the cmd prefix 

and use camelcase, like this:  

 

 

 

 

 

 

 

 

 

 

 

7. Click Finish  

   Printing   

   Other commonly used operations    

1.   Open  frmStudent   in Design view   

2.   From the Form Design Tools select the  Design   tab   

3.   Select the  Command Button tool   and draw a button in the bottom area of  

the detail section (near to the label you created earlier)   
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8. Add another button from Record Operations to Delete a Record and label it Remove 

Student.  Give is the name cmdRemoveStudent  

9. Add extra buttons from the Record Navgation category using the actions Go To First 

Record, Go To Previous Record, Go To the Next Record and God To Last Record.   

For each one use the picture option and name them with sensible names  

(eg.cmdFirstStudent, cmdNextStudent etc)  

10. Add Save Record button from the Record Operations category (give a sensible name)  

11. Add the Close Form button from the Form Operations category (give sensible name) 12. 

You’re aiming for something like this:  

  
13. Select all the buttons and make sure they are all the same height but going to Arrange 

tab > Size/space > Tallest  

14. Select all buttons and from the Arrange tab select Align > Top  

15. Distribute the buttons evenly by again selecting all the buttons and selecting Size / Space > 

Equal Horizontal  

16. “play” with the Align and Size/space options to get a professional looking interface  

It is common practice to keep user buttons away from data entry areas.  We are going to add a 

background to give a control panel effect:  

17. From the Design tab draw out a rectangle big enough to cover the buttons.  Select the 

rectangle and from the Property Sheet > Format > Special Effect chose Sunken  

18. Draw another rectangle slightly bigger that the first and position it around the first 

rectangle.  From the properties sheet> Format > Special Effect chose Raised  

19. You may wish to change the colour of the rectangle (Properties sheet > Format > Back 

Colour) to make it stand out even more.  You may need to select Send to Back  from the 

Arrange tab if the rectangle hides the buttons  
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20. When you look at your form in Form View, you’ll notice that the navigation buttons still 

appear at the bottom.  These are no longer required because you’ve added your own 

buttons.    

21. In Design view Click on the Form Selector and click on the Form  

 

 

 

 

 

 

 

 

 

 

 

22. From the Properties sheet > Format > Navigation Buttons  - set to No.  Look back at 

Form View to see the changes.  

     

Selector (top left)   
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4.9 Creating a from to display data from more than one table  

You’ve used the wizard to create useful forms.  You could also have designed a form to book 

lessons from tblLesson like this:  

 

However, this is not a user friendly form because the students would not know their ID number.  So 

to make this user friendly we’d need to see the students name on the form.  In this section you are 

going to build a form from a query which will enable us to find a student’s name  

23. From the database window, open qryLessonCost in design view.  As you can see if brings 

in fields from all the tables.  Close the query.  

24. Select Create > Form  Wizard and from the drop down list select qryLessonCost  

25. Create a well designed form with all the skills that you’ve been practicing (including disabled 

and dimmed fields, asterisks for required fields, command buttons, helpful instructions etc  

Here is the form as it is being developed:  
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5 Using SubForms  

In database systems there will be many instances where it is necessary to see data from related 

tables on one screen.  Using a SubForm is one of a number of ways of doing this: 

1. Select Create > Form Wizard and select tblinstructor from the down-down.    

2. Select this fields only InstructorID, Surname, FirstName  

3. BEFORE YOU CLICK NEXT… Now select tblLesson from the drop-down  

and add StudentID, lessonDate, StartTime and CollectionPoint from the available fields  

  

4. Click Next  

5. On the next screen select Form with subform(s) and click Next  
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6. Select Tabular from the layout options and click Next  

7.  Use these titles frmInstructorMain and fsubLesson  

  

8. “Play” in design view to improve the interface  
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5.1.1 Practice  

9. Create a form with a sub from – Firstly select tblStudent from the Form Wizard and select 

StudentID, Title, Surname, Firstname, Address1, Address2, Address3, Adress4.  

10. Before you click next select tblLesson and select Lesson no, LessonDate, Start time, 

CollectionPoint and LessonType.  

11. Select ‘Form and Sub-form’ and choose the tabular display  

12. Name the form frmStudentMain and name the subform appropriately.  

13. Use Design and layout view to improve the interface.  
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6 Setting up Reports  

In this section you will learn how to set up reports to output information.  A report is a way of 

presenting data on screen or in printed format.  Reports can be based on either tables or queries.  

1.  Setting up a report to display instructor 

contact details.  Go to Create > Report Wizard 

and select tblInstructor from the drop-down list.    

  

 

4. No sorting is needed so just click Next  

5. This is going to be a tabular report and will need to be in Landscape, select the correct 

options and click Next  

6. Finally name the report rptInstructorDetails and finish  

    

2.   Select all the fields and click Next   

  

3.   No  grouping   is required for this report so just select  Next     
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7. The report will appear in Print Preview and you should see some things that need to be 

done to improve this report:  

 

 

 

 

 

 

 

 

 

 

 

  

  

  

  

  

  

  

  

8.   Click on the  Close   Print   Preview   button.     

9.   You will see that you have the  viewing options   as follows:   

  

  

    

Title is not  

appropriate   

Instructor ID has  

been truncated   

Mobile number and  

email address have  

also been truncated   

Spacing between fields,  

field lengths and  

alignment could be  

generally improved    
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6.1 Customising a report  

10. Open rptInstructorDetails in Design view.  In the Report header area edit the report header 

to read“Instructor Contact Details”   

11. Click on the Report Header bar and go to the Properties Sheet and change the Back 

Colour to one of your choice.  Remember Accessibility and make sure the font colour is 

high contrast.  

12. I’m going to use a combination of Design View and Layout View to make this report more 

presentable – see the before and after screenshots below:  

  

 

  

Before...   

  

  

  

After...   

  

  

  

13.   Use all the  tools   in  design view   and layout view to improve your repo rt   as  

shown above     

Headings for each  

Field are now bold   

Sensible title   

All fields now  

shown in full   

More regular spacing  

between fields   

Borders removed in property  

sheet to add more consistency   
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6.1.1   Professional looking reports   

14.   Now open your  rptInstructorDetails   in Design view again and  

continue to re - design and  further i mprove this report , here are some ideas:      

  

  

  

15.   Save your report   

Address has been  

adjusted to a more  

conventional layout   

Report has  

been put into  

portrait  

orientation   

Field titles have  

been edited   

Line   has been  

added to add  

a little style   
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6.1.2 Setting up a report to display details of student lessons  

 

17. In the Grouping window, you’ll see that Access has already chosen to group this report by 

StudentID  - click Next  

18. In sorting window you are going to choose LessonDate as the field that will sort this report  

 

16.   Go to Create > Report Wizard and select  qryStudentLesson   from the drop - 

down list   -   Select all the fields and click Next   

  

in  Ascending   order and click  Next   

  

19.   This report is going to be  Stepped   and laid out in  Portrait   
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20. Name this report rptStudentLesson and click Finish  

 

21. Because you’ve based this report on a parameter query, you’ll be prompted to enter a 

student’s ID number.   Enter Student ID 1.  

 

22. You’ll see the report displaying student 1’s lesson dates in ascending order  

  

  
23. This report would, of course, need to be tidied up  
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6.1.3 Report  - Student Lessons  

24. You are going to set up a report to display details of all student lessons.      

25. Create > Report Wizard > Select qryFullDetails from the drop down  

26. Select the following fields tblStudent.FirstName, tblStudent.Surname,  

tblInstructor.FirstName, tblInstructor.Surname, LessonDate, StartTime, 

LengthOfLesson, CollectionPoint and click Next  

  
27. The next window asks how you want to view your data.  This report is going to show details 

of students’ lesson so select tblStudent and click Next  
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28. From the Grouping window Access has already added your grouping levels, so just click  

 

  

29. Sort by LessonDate and StartTime and click Next  

  
31. Name it rptStudentLessonDetails  

Next   

  

  
  

30.   Select a  Stepped  report in  Portrait   orientation   
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33. Edit the report in Layout view and Design view until it looks more like this:   

  

   

 

 

 

 

 

 

 

 

 

  

32.   The report will need improving   

  

  

If you see a line of # symbols it just  

means that field needs more space  

–   simply  widen the field in Design  

or Layout view   
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7 Calculations in a report  

7.1 Sum Function  

1. You are going to set up reports that contain calculated fields  

2. Create > Report Wizard and select qryLessonCost.    

3. Select the following fields InstructorID, tblInstructor.FirstName, tblInstructor_Surname, 

tblStudent.Firstname, tblStudent.Surname, LessonDate and TotalCost click Next  

4. Leave the grouping options as Access has already set up, click Next 5. Sort By 

LessonDate click Next  

 

6. Leave the report as a Stepped layout in Portrait  

7. Name it rptIncome and click Finish  

Open the report in Design view, you are now going to create a calculated field to show the 

grand total of all the Instructor’s lessons  

8. In Design view make the Report Footer a little deeper  
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9. From the Design tab select the Text Box icon   

10. Draw a textbox in the Report Footer, in line with the total Cost field  

  
11. Edit the label to read “Grand Total”  

12. In the control box use the SUM function to calculate the grand total of the totalCost field by 

typing =SUM(totalCost) :  

 
14. Go back to Design view and click into the control where the SUM function and open the 

Properties Sheet > Format > change to Currency  

15. Have a look in Report view  

  

13.   Check Report View and you’ll see the grand total!     

  

Need a currency  

symbol here!   
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7.2 Count Function  

16. You are now going to create a calculated field to work out how many lessons are in the 

report, for this you are going to use the COUNT function  

17. Draw another textbook in the Report folder of rptIncome  

18. In the label type “number of lessons” and in the control type =COUNT(TotalCost)  

  

19. Look at report view and you’ll see that the number of lessons in the report have been 

counted  

 

     

  

20.   Save  your report   



  

 

BTEC IT Unit 2 Microsoft Access Guide             Page  3

5 

  

8 Creating a main menu form for your database  
1. As part of creating a user interface, you’ll need to set up a menu for the users to access 

forms, queries and reports easily.  

2. Create >  Form Design  

3. You are going to be using the Design tab to create a user-friendly menu.  Go to Create >  
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Form Design .  Save the form as  frmMainMenu   

4.   Click on the  Form Selector   and then open the  Property Sheet   

and:   

a.   Add a Caption “Main Menu” (this will appear in the tab in 

Form view) 

b.   Remove Record Selectors   

c.   Remove Navigat ion Buttons   

d.   Remove Scroll Bars   

i.   Explore the other properties to  

improve your form   

5.   Click in the  Detail bar   and from the Property Sheet  

change  the Back Colour   to an appropriate one   

6.   Use all the techniques you have learned to create an  

attractive , easy to use form that   displays buttons to open :   

a.   frmStudent   

b.   frmLessonsBooking   

c.   frmInstructorMain   

d.   qryStudentLesson   

e.   qryNotPassTheory   

f.   qryDiscountCost   

g.   rptStudentLessonDetails   

h.   rptInstructorDetails   

  

Create  buttons   from the  Design tab   and find out  

how to create buttons to open forms and report and  

to run queries.   

Add  sensible   labels   which are user - friendly.     

Use  correct naming conventions   for each button  

) start with cmd (   

Put ‘instructions’ in  
a label   

Include a button to  

exit the database   

Colours, special  

effect, rectangles  

and lines for an  

attracti ve,  

accessible design   

Use alignment,  

spacing and sizing  

techniques to add  

consistency   
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8.1.1 Return to main menu button  

7. Open any of the forms that are accessed by your menu form.    

8. Add another button > Form Operations > Open form > select your main menu form  > Add 

text such as “Return to main menu” > and a sensible name  
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